over 3 years ago

For developers who want to develop Android Apps / Games on BlackBerry 10..
After Google released the ADT 23, many developers encountered the problem of can't build projects...
This version of ADT also effects on BlackBerry Plug-in for Android Development Tools.

When user try to install the plugin via this link

http://developer.blackberry.com/android/downloads/eclipseplugin/

Missing requirement: BlackBerry Eclipse Plugin for Android Development 2.0.4.201405221110 (net.rim.ajde.feature.feature.group 2.0.4.201405221110) requires 'com.android.ide.eclipse.adt.feature.group 0.0.0' but it could not be found

In version 2.0.4 (or previous 2.0 beta), developers just need to simply start the ADB proxy Manager, setup your device and then run as Android Application to deploy apps into their devices / simulators.


(Images from developer.blackberry.com)

What can we do without install the BlackBerry Plug-in for Android Development Tools??

The answer is easy... Just download the Command-line tools!!

For mac

http://developer.blackberry.com/android/downloads/fetch/BlackBerry_Tools_for_Android_Development-2.0.4-mac.zip

For Windows

http://developer.blackberry.com/android/downloads/fetch/BlackBerry_Tools_for_Android_Development-2.0.4-windows.zip

For Linux

http://developer.blackberry.com/android/downloads/fetch/BlackBerry_Tools_for_Android_Development-2.0.4-linux.tar.gz

After you download the file, you can see several files inside.
Open the "ADB Proxy Manager" and setup your device, just like what you did in eclipse!

Now you can go back to your development and don't need to worry about no eclipse plugin!!
Thanks for BlackBerry!

Keep Developing!

← How to update your Dev Alpha software? Welcome! the Brand New BlackBerry Vendor Portal! →
 
comments powered by Disqus